Cannot launch AVD in emulator

0 akash kajaria · October 16, 2015
Cannot launch AVD in emulator.
Output:
emulator: ERROR: x86 emulation currently requires hardware acceleration!
Please ensure Intel HAXM is properly installed and usable.
CPU acceleration status: HAX kernel module is not installed!


I'm stuck up here .Suggest a solution

Post a Reply

Replies

Oldest  Newest  Rating
0 bobby miller · October 17, 2015
First open the sdk manager & make sure the package Intell x86 emulator Accelerator (HAXM installer) is installed. It is at the bottom of page in the "extras" folder. Then go to file manager and follow the path C:/ Users/(your comp name)/AppData/Local/ Android/sdk/Extras/Intel/Hardware_Accelerator_Execution_Manager then right click on intelhaxm-android(application file) choose run as addmin and run the installer. You will have to turn on "show hidden files" If you don't know how to turn on hidden files...google it. Go back & re run emulator
0 Chris Daniel · October 17, 2015
After you install the HAXM package, make sure that your processor supports VT-x (Virtualization Technology). If it supports but still throws up that message you need to enable it from BIOS by enabling Hardware Virtualization. If your processor does not support VT-x then you will need to upgrade your processor or use a physical device (its faster than the emulator).
0 akash kajaria · October 21, 2015
Well,thanks a lot  Bobby and Chris ,the solutions works . Anyways I'm facing with one more problem which is shown in the image below .As you can see there is a cross mark on the debug icon.Also I cant find the design/text options on my screen. What could probably go wrong? 
/images/forum/upload/2015-10-21/6411c519b314bbe81065e0663ab2f9e7.jpg
0 JACOB AMBA · October 23, 2015
Thank you Bobby for the solution. I had the same error I have done upto running the administrator. What I still dont understand is what should be turned on and how to turn them on. Please Help. You are my google lol!!
0 JACOB AMBA · October 23, 2015
Thank you Bobby for the solution. I had the same error I have done upto running the administrator. What I still dont understand is what should be turned on and how to turn them on. Please Help. You are my google lol!!
0 JACOB AMBA · October 23, 2015
emulator: device fd:760
HAXM is not working and emulator runs in emulation mode
emulator: The memory needed by this AVD exceeds the max specified in your HAXM configuration.
emulator: AVD      RAM size = 1536 MB
emulator: HAXM max RAM size = 1024 MB
emulator: You might want to adjust your AVD RAM size and/or HAXM configuration to run in fast virt mode.
creating window 43 59 329 583
emulator: emulator window was out of view and was recentered
emulator: UpdateChecker: skipped version check

This is another problem I currently ran into.  any help how to correct
  • 1

Java / Android Development

107,096 followers
About

Very popular language used to create desktop applications, website applets, and Android apps.

Links
Moderators
Bucky Roberts Administrator