Question about Android App Development for Beginners - 4 - Running a Simple App

+1 Priyabrata Das · September 28, 2015
When I run the simulator phone Nexus 5 in AVD manager, then instead of running it shows :
Cannot launch AVD in emulator.
emulator: ERROR: x86 emulation currently requires hardware acceleration!
Please ensure Intel HAXM is properly installed and usable.
CPU acceleration status: HAX kernel module is not installed!

Would anyone please help me in resolving this???

Post a Reply


Oldest  Newest  Rating
0 K'Ci Beckford · September 29, 2015

You need to open the SDK Manager and install "Intel x86 Emulator Accelerator (HAXM installer)".

When you open the SDK it should have some pre-selected options for you install and update so just find the thing to install above and install them all.
0 Joanna Mikova · September 29, 2015
I have the same problem 
0 Gabriel James · September 28, 2015
search on the previous quotes on this forum u see the answer u seek . though i could
not remember the way i solved mine
0 Gary Whitney · September 28, 2015
This is the most frequently asked question.
There is a public serviced post that deals with this.
The short answer is you need to have a newer Intel processor and a bios that supports this.

Here is how I resolved it.

Found this link and followed instructions for installing using Studio >  Tools > Android> SDK Manager
  • 1

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator