HAXM is not working and emulator runs in emulation mode

+1 Shyam Mohan · September 19, 2015
When I try to run my first application, the emulator simply shows android, like it is booting and nothing more. How can I solve this problem? Posting the code shown.

emulator: device fd:848
HAXM is not working and emulator runs in emulation mode
emulator: The memory needed by this AVD exceeds the max specified in your HAXM configuration.
emulator: AVD      RAM size = 1536 MB
emulator: HAXM max RAM size = 512 MB
emulator: You might want to adjust your AVD RAM size and/or HAXM configuration to run in fast virt mode.
creating window 43 59 329 583
emulator: emulator window was out of view and was recentered

Post a Reply


Oldest  Newest  Rating
0 Rakshanda Phate · December 7, 2015
Your solution is here: http://howcanicode.com/2015/12/emulator-error-x86-emulation-currently-requires-hardware-acceleration/
0 Archit Kapoor · September 21, 2015
Hello Shyam, well it seems you have to fix a lot of things. I have faced similar issues too. So follow the steps below(you may have already some of them):

1) Uninstall any anti-virus(usually Avast troubles)

2) Re-boot and go to BIOS and enable support for Virtualization. So make sure you enable VIrtualization, and save the settings/changes and proceed.

3) Open Android Studio(run with Administrator privileges,though not necessarily) and then open Android SDK Manager.

4) Have you installed Android Support Repository and Intel X86 Emulator Accelerator(HAXM installer) ? If not, then select those packages in Android SDK Manager and install them.

5) Next, go to C:\Users\...\AppData\Local\Android\sdk..\extras\intel\Hardware_Accelerated_Execution_Manager and double clicked on intelhaxm-android.exe. Not necessarily but I would suggest to run it with Administrator privileges.

6) Now you need to change some of the settings first of all. While installing HAXM prior to posting this question on the forum or through following the steps I have given above, your HAXM max RAM is 512 MB. While the Android Virtual Device you are running  needs 1536MB of RAM. So it's like the phone you are emulating has RAM of 1536 MB but HAXM is not permitted to provide this much of RAM.
It is quite possible that your system doesn't have high RAM, as in 12 GB or 16 GB. For 4-6GB RAM systems, HAXM is set between 512 MB to 1024(or 1536MB) RAM.
So now you can do three options:
a) Create a virtual device with RAM size 512 MB and run it with the current HAXM configurations.

b) Increase HAXM max RAM size to 1536 MB. This could significantly impact your system's performance. Why? Because when you choose to do so, OS would reserve 1536 MB of your system's RAM for HAXM.

c) Better than the above two. Increase HAXM size to 768 MB(512+256). Keep it less than equal to 1024 MB. Then reduce the AVD RAM size to the max RAM size of HAXM. Like if you choose to keep HAXM RAM size to 768 MB then create/modify your AVD with RAM size 512MB or 768MB RAM.

Again, to modify HAXM settings, follow step 5.

Keep one thing in mind, when you are running AVD for the first time, it takes a lot of time. So be patient.
Following the above procedure, should fix the problem in my view.
0 Shijun Ju · November 17, 2015
You may want to look at this video:  https://www.youtube.com/watch?v=ZLcozYGkxl0
It solved the problem for me.
During the process, if it still not works, try restarting the android studio.

-Also a beginner
0 Chetan Ingle · December 8, 2015
well here one more solution for your problem.
install a software called "bluestack" . open it.
then run ur android program and select "choose a running device" option and press OK
u will get ur app running on bluestack
do that and let me know if is works for u!!
0 Shijun Ju · November 17, 2015
There are at least two youtube videos discussing the problem. They solved the problem for me. During the process, you may want to restart your android studio.

-also a beginner
0 Guddu Kumar · October 19, 2015
@ Archit,
I created a AVD with ram 512 MB, i got a warning
- Increasing RAM Size to 1 GB

then got a message

HAXM is not working and emulator runs in emulation mode.

Please help me out.
0 Lara Delestre · September 24, 2015
I install the HAXM manually and gives me the error: "VT-x disable", I verified my BiOS and is enable. What else I can do?
  • 1

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator