C:\Users\hi\android-sdks\tools\emulator.exe -avd MyAVD
emulator: ERROR: x86 emulation currently requires hardware acceleration!
Please ensure Intel HAXM is properly installed and usable.
CPU acceleration status: HAX kernel module is not installed!

i have already installed HAXM ... n it shows installed in the SDK manager


got that.....

For me the first solution was to modify the Emulator to use arm-cpu instead of x86.

second solution:
C:\Users\hi\android-sdks - take this address from the above error message and o to this address .. you will find a folder - extras
In extras run the haxm set up…
Remember the ram space
now in studio - go to avd manager and by clicking the pencil icon Edit the avd to that same ram space by clicking the pencil icon  (you will find it in advanced settings)…
Save avd changes and now run…