Error opening virtual device... PLEASE HELP

0 Bar Benaim · August 20, 2015
I'm new to android developing and I recently watched the 4th video tutorial of thenewboston
anyways I just made my first project and while trying to open my virtual device as said in the tutorial it came up with an error
saying: Output:
emulator: ERROR: x86 emulation currently requires hardware acceleration!
Please ensure Intel HAXM is properly installed and usable.
CPU acceleration status: HAX kernel module is not installed!
Thanks for reading if anyone can help... sorry i'm a beginner so please explain what the problem is and Thanks for helping!

Post a Reply


Oldest  Newest  Rating
0 Hamza Nasim · August 21, 2015
Firstly open your sdk manager and scroll down to the last. There you will see the package Intel x86 Emulator accelerator HAXM. Install it. Then go to C:\Users\home\AppData\Local\Android\sdk\extras\intel\Hardware_Accelerated_Execution_Manager and run intelhaxm-android.exe. The haxm will be installed and will be ready to use. An error may occur while installing saying "The computer meets the requirement for haxm bot the Intel virtualization technology is not turned on. To enable this technology you have to acces your BIOS.
0 ravi maurya · August 21, 2015
hi i'm a beginner too. What can I do if my computer does not support virtualization technology.please help me out in using virtual device or any other way to test my app.
0 Dol Lod · August 22, 2015
get an android phone and enable developer options. Allow third party apps to be installed. Then just run your app on your phone.
0 ravi maurya · August 22, 2015
Thanks @Arjun. I tried with another emulator and finally it worked with Genymotion.
  • 1

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator