error in android studio

+2 nathan rogers · August 5, 2015
i keep getting this code when try to run the emulator
emulator: ERROR: x86 emulation currently requires hardware acceleration!
Please ensure Intel HAXM is properly installed and usable.
CPU acceleration status: HAX kernel module is not installed!
if i go to sdk manager i have it installed so i dont understand why im getting this error

Post a Reply

Replies

Oldest  Newest  Rating
0 Rafat Shakil · August 6, 2015
This happened to me as well but I got a solution that worked for me. (Ripped off from a YouTube Comment).

THERE ARE 2 STEPS: 1st Step: -Go to Tools>Android>SDK Manager
-Scroll to the very bottom and ensure 'Intel x86 Emulator Accelerator (HAXM installer)' is installed (install it if it isn't by checking the box on the left and clicking 'Install package'


2nd Step: -Go to Tools>Android>AVD Manager -Click Create Virtual Device,
Choose Nexus 6 (don't know all of them that work but this definitely worked for me).
Click Next. -Click the top choice (Lollipop | 21 | armeabi-v7a | 5.0.1) (again, worked for me) -Click Finish. This solved my problem. Hopefully it helps you too!

s/o Cody Morgan
  • 1

Java / Android Development

106,948 followers
About

Very popular language used to create desktop applications, website applets, and Android apps.

Links
Moderators
Bucky Roberts Administrator