Android Studio AVD emulator error

+3 Sonja Mijatovic · July 6, 2015
I installed Android Studio following tutorial instructions. When trying to launch default Nexus AVD in emulator I get this error messange:
Cannot launch AVD in emulator.
Output:
emulator: ERROR: x86 emulation currently requires hardware acceleration!
Please ensure Intel HAXM is properly installed and useable.
CPU acceleration status: HAX karnel module is not installed!

Of course, I did install Intel x86 Emulator Accelerator in Android SDK Manager but I can't find SDK on default location mentiond on some forums (C:\users\username\AppData\Local\Android\sdk).

Please help me start developing,
Thanks in advance :)

Post a Reply

Replies

- page 1
Oldest  Newest  Rating
0 Susmeet Jain · September 6, 2015
I am getting a similar problem on my mac running on OS X Mavericks, 4gb ram, i5
When I click on the device, it does launch, but it continues to stay over the initial screen with android written in the middle of it, it has been over half an hour.
0 Matthew W · September 4, 2015
What do you mean it doesn't launch, what happens when you click on the AVD icon?
0 Yash Mohite · August 26, 2015
guys my avd does not launch at all
pls help !!!
0 Matthew W · August 24, 2015
https://www.thenewboston.com/forum/topic.php?id=3853
0 Rahul Ragesh · July 9, 2015
I solved it by doing this.

1.Go to the virtual device manager.
2. Add a new virtual device.
3. Go with the default settings except that in CPU/ABI column.. Change it from Intel Atom (x86) to ARM(armeabi-v7a).

Let me if that solved your issue!!:)
0 Sunny Doultani · July 8, 2015
I got the same problem..tried to reduce the ram of the avd to 512mb but it still stops working..please help
0 MUHAMMED ASLAM HARIFF · July 8, 2015
thanks a lot guys
0 Tony Stark · July 7, 2015
Use genymotion, its easier. get it here -> https://www.genymotion.com/#!/
0 MUHAMMED ASLAM HARIFF · July 7, 2015
hey i have got the same problem 

SOMEONE PLEASE HELP !!!
0 Deborah Clark · July 7, 2015
Hi folks!
I had the same error when I set up my Android Studio - After searching for the error, I had to 
go to my bios and turn on hardware virtualization.
I found a good thread for several solutions explained(the accelerator sdk is one of them) at Stack Overflow, here's the link:
http://stackoverflow.com/questions/27720064/hax-kernel-module-is-not-installed

I hope this helps you as well as it helped me!:)
  • 1
  • 2

Java / Android Development

107,094 followers
About

Very popular language used to create desktop applications, website applets, and Android apps.

Links
Moderators
Bucky Roberts Administrator