android studio unable to start daemon process

+3 jordan thompson · July 1, 2015
Hi can anyone help me I have just started Bucky Roberts android app development tutorial I am on video 4. When creating my android project an error occured and I recieved a blank, project. 

The error says in the message gradle sync at the bottom that: 

my 'my Application' project refresh failed 

Error:Unable to start the daemon process. 
This problem might be caused by incorrect configuration of the daemon. 
For example, an unrecognized jvm option is used. 
Please refer to the user guide chapter on the daemon athttp://gradle.org/docs/2.2.1/userguide/gradle_daemon.html 
Please read the following process output to find out more: 
----------------------- 
Error occurred during initialization of VM 
Could not reserve enough space for object heap 
Error: Could not create the Java Virtual Machine. 
Error: A fatal exception has occurred. Program will exit. 

Anybody know whats going on I am eager to get on to the next videos. 

Thanks in advance 
Jordan 

Post a Reply

Replies

Oldest  Newest  Rating
0 jordan thompson · July 1, 2015
Thanks man never even thought of that your awesome:D
0 omeshwar darlz · September 28, 2015
yaaa....no..change
0 John Doe · August 16, 2015
GOOD GOD!!!! i tried everything..... EVERYTHING!!!!! and nothing has fixed this problem. someone please help! i have spent the last 4 days googling and nothing has fixed this problem.
0 Paulo Oliveira · November 1, 2016
I've been researching this error and I found the answer after searching a little bit and found the answer. 

I find the answer in the website: https://www.experts-exchange.com/questions/28828160/Android-Studio-Gradle-project-sync-failed.html

This problem occurs because of memory reserved for the IDE it is too low. so what we need to do is override them.

Proceed like this...

With Android IDE open, just only add this line of code in **gradle.properties**

    org.gradle.jvmargs=-Xmx1024m -XX\:MaxPermSize\=512m

and now u click in *Try Again...*

Your file will look like this:
------------------------------


----------


    org.gradle.jvmargs=-Xmx1024m -XX\:MaxPermSize\=512m
    
    # Project-wide Gradle settings.
    
    # IDE (e.g. Android Studio) users:
    # Gradle settings configured through the IDE *will override*
    # any settings specified in this file.
    
    # For more details on how to configure your build environment visit
    # http://www.gradle.org/docs/current/userguide/build_environment.html
    
    # Specifies the JVM arguments used for the daemon process.
    # The setting is particularly useful for tweaking memory settings.
    
    # When configured, Gradle will run in incubating parallel mode.
    # This option should only be used with decoupled projects. More details, visit
    # http://www.gradle.org/docs/current/userguide/multi_project_builds.html#sec:decoupled_projects
    # org.gradle.parallel=true


----------


I hope it helped you.
  • 1

Java / Android Development

107,134 followers
About

Very popular language used to create desktop applications, website applets, and Android apps.

Links
Moderators
Bucky Roberts Administrator