Original Issue: Had a finalized app that I wanted to integrate Admob Ads into. I followed an online tutorial on how to do this and it broke my app. Gave me the error "Cannot resolve symbol" on all imports.

What I have tried: (In all instances I get "Cannot resolve symbol on all imports")

1. Closed app and reloaded backup copy that was working previously.
2. Started a brand new APP and copied all my saved code.
3. Even when starting completely new apps I get same error before doing any coding.
4. Invalidated/restarted cache.
5. Deleted .idea folder
6. Clean/rebuild project
7. Changed my Compile and Build Tools version
8. Uninstalled Android Studio and reinstalled
9. Uninstalled Android Studio, Java JDK, and Java.
10. Reinstalled x64 Java, Java JDK, and Android Studio and changed Environment Variables to point to jdk.
11. After finishing fresh install and starting a brand new project same issue.
12. EVERYTHING on my SDK Manager is installed minus the Android SDK Platform-tools version 22 and that is because the Android SDK Platform-tools version 23rc2 is installed. (Each time I install one the other is uninstalled)
13. Synced Gradle files

All of these solutions I researched and found online. None of which worked. Any help or ideas? Thanks.