Failed to install Intel HAXM

+1 tz Lim · June 1, 2015
My programming background is weak. I am interested to learn to develop android application. However, I was stuck in the installation process while I was following some tutorial videos in YouTube.

I had install java jdk, yet the error massage as below pop up during the installation of Android studio.

Failed to install Intel HAXM. For details, please check the installation log:

Please advice. Thanks a lot.....

Post a Reply


Oldest  Newest  Rating
0 peter gongora · June 1, 2015
intel HAXM is only for intel processors and some AMD i think but if youve got AMD you should better try using genymotion as emulator.
0 Elliott Porter · June 1, 2015
You might have to enable the Virtual Machine in order to run the emulator and install HAXM.
Restart your computer, go into the BIOS, and enable VM. Then try reinstalling it again
0 Ayk Badalyan · June 2, 2015
btw, Genymotion is working really better and faster.

Here it is:!/
0 Jeff T. · June 2, 2015
  I had the same problem 2 days ago when I installed the program, this is what worked for me. Check out this video (link below), it's only about 2 min. and the small program to download is safe, I did it, no problems, delete it when your done if you want to (has good info about the comp. though, I kept it). This will let you know if your computer is compatible, if it's not try another program listed  in the other comments/ forums.
  If it is compatible and enabled, make sure you have downloaded the file in the SDK manager per Bucky"s tutorial. Next navigate to this location/ folder(this should be where the file was downloaded) ;

C:\Users\<Your Name>\AppData\Local\Android\sdk\extras\intel\Hardware_Accelerated_Execution_Manager

There should be a file named 'intelhaxm-android.exe'. Double click it and it should launch the installer. Just follow the directions and it will install the needed files. If for some reason you don't have that file you can try to download it again through Android Studio SDK manager or google intel HAXM and download the file from intel.  

The main thing is making sure you computer can run it. Many older ones can't. This worked for me, it downloaded the file correctly but for some reason it didn't install it so that's all you need to do, install it manually. And once launched in Android Studio, it does take a couple of minutes to run and start the VM phone, so be patient. I wasn't and kept hitting run every minute or so, then 4 phones popped up at once with a warning that I was using more MB than was allotted and I should change the settings, pretty funny.

Good luck, hope this works.
0 Matthew W · August 24, 2015
  • 1

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator