Android Studio Cannot Resolve Anything

0 Çağlan Turgut · May 28, 2015
I've been using Android Studio for about one and a half month. I think its way better than eclipse in some cases. I've recently updated my Android Studio version and downloaded API Level 22.

And now none of the projects are working.

I've changed all of my projects to use API 22 but it didn't help.It cannot resolve ActionBarActivity, setContentView etc. I have tried reinstalling the SDK. It just says "Cannot resolve method xxx" or "Cannot resolve symbol xxx".

I also tried Invalidating Caches but it didn't do any difference. All the gradle files are looking ok but even the sample projects are not building.

I cannot code anything right now and my customers are waiting a demo from me in a week. I'm really stuck, any help/suggestion would be appreciated. Do you have any suggestion ont the topic? I'm thinking of formatting the whole computer :(.
Thanks in Advance.

Post a Reply


Oldest  Newest  Rating
+1 Ian Arbuckle · May 30, 2015
Just beware that with directories that they have no space or special characters in between them.
0 Çağlan Turgut · May 29, 2015
Yes, I did :(.

EDIT: Oh, wait I think I solved the problem. It seems to be working fine right now. I guess it had a problem  with non-latin characters in project directory. Well, it was working fine before the update so I never thought it could be that. Maybe it was something else that got fixed after changing the directory to C:/Android/Project. Whatever... Thank you for your interest tho.
0 Firman Qodri · May 29, 2015
did you install Android Support Repository on SDK manager?
  • 1

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator