rendering problem in android studio

+2 ashbir duggal · April 28, 2015
my emulator is not running on android studio.

Post a Reply


Oldest  Newest  Rating
0 Radomir Kolev · April 28, 2015
Hello, I got familiar problem. This error appears and I don't know what to do.

Also I can't see the phone in the activity_main menu
0 Radomir Kolev · April 29, 2015
@ashbir duggal

I am currently struggling with the same type of error and I was browsing the whole internet for solution. Take my advice :

1) First of all check if your processor is supporting Virtualization.
2) If it is go to BIOS and change  the virtualization from OFF to ON.
3) Go to the location where SDK manager is installed. /Mine is in C/User//AppData/Roaming/sdk   -Note that AppData folder is hidden -
4)When you enter sdk folder go to ->extras->intel->hardware_accelerated_execution_manager and install intelhaxm-android

That will do the trick.
0 ashbir duggal · May 1, 2015


ALSO WHEN I RUN MY HELLO WORLD PROG ITS SHOWS A MESSAGE "hax is not working and emulator runs in emulation mode"

i have unistalled android studio and will install it once again if no solution is there ....then i will start my android journey with eclipse....
0 Radomir Kolev · May 3, 2015
Since my processor is not supporting virtualization I am testing my future apps on my physical phone device. It is solution for the moment.
0 Radomir Kolev · May 5, 2015
Hi again, in case somebody ever occur on the same problem like me in the second post here is the solution that is working for me : 

Click the little android guy in the top right /next to the Component Tree window/ and change from API 22 Android 5.1.1 to API 21 Android 5.0.1 and the little phone will appear.
0 steve Jones · May 21, 2015
Hello, I Just started learning about Android development, Loaded Android Studio all is well however the preview window is not displaying anything. Everything else is working, compiling, and running in the simulator.

I have tried all (I think) the fixes I've found online but with no effect on the problem. I have tried to change the Android version setting...set the environment variables for JAVA_HOME and JDK_HOME to my "..\java\jdk1.8.0_45" directory... I have all every SDK file installed from API 18-22, all the tools and extras...project structure settings for SDK and JDK paths are correct...

Does anyone have the correct fix for this? Thanks in advance.

The message in the preview window is:

"Rendering Problems
Failed to load platform rendering library"

  • 1

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator