Adb Transfer Protocol Error

+1 Chagit Hazani · April 21, 2015
First time working with Adndroid Studio. When worked with Eclipse, all worked ok.
I get this error:

Adb Transfer Protocol Error.

Read-only file system

Any ideas what to do?
Thanks a lot

Post a Reply


Oldest  Newest  Rating
0 Minoes Tback · September 28, 2016
There is  a program called MobileGo which uses adb for file transfer. You can check the source code. Here is the detail:
0 Gary Whitney · September 28, 2016
This post states to delete your device and clone a new one.
I didn't find a definitive answer here

So I would:
* delete the device.
* Install any updates
* Clone a device that matches your CPU.
0 tella q · November 29, 2016
Maybe you can check your adb connection,  if your adb is working properly. The quick and easy way is to get a android manager on the device that can gain root access, find the \data\local\tmp folder and edit it's properties to give full read write and execute permissions.
0 Kuroodo Ditory · April 21, 2015
You already made a post. Please do not double post. If no one has helped you yet, be patient.

Also in the mean time, try using google to find your answer. If you found a solution, please share it here as well (on your first post, not this one).
  • 1

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator