Pycharm on Linux is ssssllloooowwwww

0 Cardinal Coog · February 16, 2015
I recently switched from IDLE (using Python-3.4) to Pycharm Community 4.0.4 on Linux Mint 17.1.
IDLE runs smooth and fast. Pycharm, on the other hand, is beyond painfully slow.
Almost to the point of click on <File>, go smoke a cigarette, and MAYBE a new window will be open when you return.

This can't possibly be normal. Is anyone else having this problem?

Anyone know of a way to speed Pycharm up?


Post a Reply


Oldest  Newest  Rating
0 Bernard Pyc0d333 Parah · February 16, 2015
had the same problem on my first installation on kali last year, i just uninstalled it and installed again. worked perfectly ever since
0 Tatrasiel R · February 17, 2015
Are you running this in a VM? I have only seen these problems in VM's I run Pyharm in Linux and it runs superbly well.
0 Cardinal Coog · February 17, 2015

Yes. I'm running Linux Mint in an Oracle VM. Unfortunately, a VM is my only option right now.
0 Tatrasiel R · February 17, 2015
Maybe you should consider dual boot or boot off of USB. Otherwise, I don't really see another option. To be honest, I don't know why Pycharm does this, but it might be related to IO and reading off the VMware image; I am not sure however.
  • 1



This section is all about snakes! Just kidding.

Bucky Roberts Administrator