Tutorials 49-54

+3 Jose Munoz · February 13, 2015
I thought I followed all of the steps, but it aborts with "Unfortunately SQLiteChap49 has stopped", where SQLiteChap49 is the name of the app.
The entry screen does not show up, so I'm thinking the problem is in MyDBHandler, I commented out the call to printDatabase() in MainActivity.  Sure enough, the screen then showed up but got an error as soon as I entered a product.

So I concluded the problem must be in databaseToString().  I put Log statement upon entering, just before the 
 SQLiteDatabase db = getWritableDatabase(); statement and just after that statement.  I get the just before Log but not the after Log.  "Something's" wrong with  SQLiteDatabase db = getWritableDatabase(); but I dont know what.

Ive tried running debug but that also fails.

I tried on my physical device, and that also failed.

Seems as if it cannot create the database, but I dont know why.

Post a Reply


Oldest  Newest  Rating
+2 castulo ramirez · June 26, 2015
Check this out


I have tried it, after It worked
  • 1

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator