Can't open Emulator in Android Studio

+1 marlou gielen · February 12, 2015
Hi everyone,

I'm new to the App building and Android Studio so I have been following the tutorials on youtube.
I followed all the steps in installing packages and so on...
But I can't seem to open the emulator, every time i click play I get a warning that says:

C:\Users\Marlou\AppData\Local\Android\sdk\tools\emulator.exe -avd Nexus_5_API_21_x86 -netspeed full -netdelay none
emulator: ERROR: x86 emulation currently requires hardware acceleration!
Please ensure Intel HAXM is properly installed and usable.
CPU acceleration status: HAX kernel module is not installed!

When I check the SDK Manager it says that my Intel x86 emulator accelarator (HAXM installer) 5.2 is installed.

Doen anyone know how I can fix this problem?

Already thanks for the help

Post a Reply

Replies

Oldest  Newest  Rating
0 Steve O · February 12, 2015
Hi Marlou,

I think the information in this thread:

https://www.thenewboston.com/forum/topic.php?id=3853

will give you the information you need.

HTH
Steve
0 kate N · February 13, 2015
Hi Steve . 

Even i am facing 

emulator: ERROR: x86 emulation currently requires hardware acceleration!
Please ensure Intel HAXM is properly installed and usable.
CPU acceleration status: HAX kernel module is not installed!

When I check the SDK Manager it says that my Intel x86 emulator accelarator (HAXM installer) 5.2 is installed.

I installed INTEL DIAGONISTIC TOOL , GENYMOTION , HAXM INSTALLATION. 

But still the problem has not solved.
0 kate N · February 13, 2015
hi marlou gielen 

I am also facing same problem ,

Have you succeeded in solving the problem,

If yes! Then please help me out

regards,
0 Carl Brown · February 15, 2015
i am also experiencing the same issue. I too followed the youtube tutorial to the letter???
0 Kaushal Jain · February 15, 2015
Even i am facing the same problem..
I followed everything bucky said in the tutorial and yet when i launch the emulator, it says intel x86 HAXM not installed or if installed please ensure that it is usable!!1

Please help me out!!!
0 Quick Shark · February 15, 2015
Create a new device with an ARM OS, instead of the default x86. Sometimes, using the ARM with the Nexus 5 gives problems. In that case, just use another device. I use the Google Nexus. 
And if you can't find the ARM OS under device manager, open Android SDK manager and download the ARM OS.
Its just an emulator, so you just need to test the program and has nothing to do with other compatibility issue. The only difference that's gonna be there in using x86 is a bit increase in speed.
/images/forum/upload/2015-02-15/6aa993c478e2b34fa7ddc63e8a051794.JPG
0 harsh varshney · February 15, 2015
Had the same problem..
thetaylorsthread.com/please-ensure-intel-haxm-is-properly-installed-and-usable/
0 Chitral Verma · February 15, 2015
for all of you who're having problems with emulator (HAXM or KVM etc) it just means that that your hardware precisely your CPU isnt capable of performing enhanced tasks like virtualisation.

So, youll have to select the ARM images for your virtual devices.
My guess is that if your pc can't use x86 images, the ARM images would also be laggy and slow.

I suggest you to connect your actual android phone to your device in debugging mode via adb and use it instead of a virtual machine. youll save lots of time and your experience will be real.

profit.  
0 Steve DeRosa · February 17, 2015
 I had the same problem and the error was a memory problem.  I increased the virtual memory to 1 GB and it solved the problem.
  • 1

Java / Android Development

107,234 followers
About

Very popular language used to create desktop applications, website applets, and Android apps.

Links
Moderators
Bucky Roberts Administrator