Android studio

+3 Yousef Shaaban · February 10, 2015
when i tab on the ( Run as administrator ) tab this window shows up 

( the environment variable JAVA_HOME( with the value of C:/program files/JAVA) does not point to valid JVM installation.)

PLEASE HELP 

Post a Reply

Replies

- page 1
Oldest  Newest  Rating
+2 Jaytee Bourne · February 10, 2015
Hi Yousef Shaaban,

The problem to your solution may be to:

first go in to command prompt (CMD) in windows and type:

java -version 

this will then provide the information on the version you are currently running. 

Once that is determined if you are running java version which is  "1.6.0_22"  for an example, you may want to consider upgrading your JDK to 1.7


Please let me know if this helped, if not we can determine to resolve this in another way. 

Hope this helps.
+1 Yousef Shaaban · February 11, 2015
/images/forum/upload/2015-02-10/c6608c9a658562235a3887b7b626d356.jpg
CHECK THIS OUT 
+1 Jaytee Bourne · February 11, 2015
Brilliant your ready to go.

Nice working with you Yousef Shaaban.

I guess updating the JDK then re-modifying the variable done the trick. 

If you wish give a like on the left hand side to improve the rating for others as well that would be great.

Brilliant updates/posts. Hope to help in the future again.

Good-man.

Take care.
+1 Jaytee Bourne · February 11, 2015
Hi Yousef Shaaban,

You will find computers can be stubborn. In this case i have answered this question already please go into the Forum Section and check for  the title:


"There is no way to enable virtualization in bios on HP 4710s notebook "


You will find a set of instruction by me in there. 


If your problem still occurs then please contact me back here and will answer any questions you may have. 

Before you do so Please check you have INTEL CPU and what version it is. 

Once the version is determined please check that is supports the virtualization you can find this out by typing the full CPU name in google and click on the webpage which has  "ARK |"  at the start scroll down and look for "Intel® Virtualization Technology (VT-x) "


if that feature is ticked or green you will need to go into your bios by restarting your computer and pressing the HOT KEY in the case referred to the letter and number such as f10 or f11 at initialization. You can then check CAREFULLY if it is enabled or not everybody BIOS is different so look carefully.

Also check if your ANTI-Virus is not blocking it. 

You should only carry out the above once you have checked the INTEL CPU supports "Intel® Virtualization Technology (VT-x) ".


If not please refer to forum by clicking on forum then on the right hand side click on "Java / Android Development" then scroll down and look for the title:


 "There is no way to enable virtualization in bios on HP 4710s notebook "

I have also provided a direct link to the solution:

 https://www.thenewboston.com/forum/topic.php?id=4755


(if the post is not their yet the set of instructions with a print screen which should be the fifth post it's because the post is being verified.)

Please don't forget to rate it up so others can see too, as always you have been great. 

Take Care.
+1 Jaytee Bourne · February 12, 2015
Yes that's right for which reason i said to check the bios first.

Good-man.

Anytime.
0 Yousef Shaaban · February 10, 2015
OKAY I have done it :)

I've changed the location of the variable to the location of the second file in C:/programs/JAVA

thanks anyway !
0 Yousef Shaaban · February 11, 2015
Alright I figured it out " I think "
I have changed the location of the variable 
Fingers crossed that it does not give me any errors 

Thanks anyway ????
0 Jaytee Bourne · February 11, 2015
Hi again,

Did your problem resolve to changing the variable JDK version or the path was incorrect? 

As you said you had changed the location of the variable.

for instance C:\Program Files\Java\jdk1.8.0_25

Further more can you confirm that it didn't work due to a incorrect path or when you updated your JDK you the re-entered the version in the HOME_JAVA variable or if it was edited in another way perhaps...

Btw thank you for keeping me up to date on the matter. 
0 Yousef Shaaban · February 11, 2015
* No problem * The location that I put is this C:\Program Files\Java\jdk1.8.0_25
After that I reopened Android studio it gave me the picture that I showed you earlier

I hope for no problem ????
0 Yousef Shaaban · February 11, 2015
Seems like errors is my " THING " 


/images/forum/upload/2015-02-11/b50d9235815964b39fda9865e729e55f.png
  • 1
  • 2

Java / Android Development

107,161 followers
About

Very popular language used to create desktop applications, website applets, and Android apps.

Links
Moderators
Bucky Roberts Administrator