I do not have VT-x on my computer (Help!)

0 Andrey Markov · January 3, 2015
I tried my to test my app on the emulator but I got an error saying my haxm is not properly installed or usable so I checked my sdk manager again and say that it was installed but I did some research and found you have to install the haxm file from this location C:\Users\User\AppData\Local\Android\sdk1\extras\intel\Hardware_Accelerated_Execution_Manager and I tried installing the file but an error came up saying my computer does not support/ have VT-x so I can't install the file. I tried everything to fix this I turned on virtualization technology by going to my UEFI then to the BIOS menu. I tried turning on/off my hyper-v in the windows feature on/off but I don't have hyper-v. I did the cold restart. I did all these things with no success. So could someone PLEASE assist me in solving this problem. Thank you :)

Post a Reply


Oldest  Newest  Rating
+1 ahmedtarek mahmoud · January 6, 2015
better use an android   mobile phone as an emulator
0 servet portakal · January 6, 2015
I suffer from the same thing. My CPU is a Core 2 Duo without VT-x.  What I am doing is to choose the arm based image while creating my V?rtual Device. It doesn't run very well; I receive errors, but it runs the apps. So, for now it is an okay solution.

If anyone has something to add on this, it would be great.
  • 1

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator