Sample App issues with HAX / emulation memory issues

+2 Marc Ferrari · January 2, 2015
Greetings!  I hope everyone had a pleasant New Years!

I worked my way up to video 4 of the new android app videos.  When I attempted to load the "Nexus 5" through the AVD manager I received the following message.

HAX is not working and emulator runs in emulation mode
emulator: The memory needed by this VM exceeds the driver limit.

I attempted to search for responses and most I was able to find through Google indicate that this is a memory issues with the AVD/Java not having enough memory accessible to the android device I'm trying to create?  Most seemed to suggest making sure the memory was between 500mb and 1000mb.  When I checked out the settings for the Nexus it had 20mb set.  

I updated the memory to 512mb and per the suggestions I found through goggling deleted and then re-installed the HAX.  

Once I reloaded and attempted to run the Nexus again it worked and the faux phone appeared on my screen however I'm still receiving the messages listed above.  Any thoughts as to what I should be looking at next because the only suggestions I found were referencing increasing the available memory size. 

Thank you!

Post a Reply


Oldest  Newest  Rating
0 Marc Ferrari · January 4, 2015
Define didn't work... did you get messages similar to the ones I pasted above?
0 Marc Ferrari · January 3, 2015
Ok so I've double checked a few things.  

1. The SDK for HAX is definitely installed
2. VM is definitely turned on in the BIOS. 
3. Definitely running and Intel CPU  (Intel Core I5 750 @ 2.67GHz)
4. Have 4gb ram, 1of which is allotted to HAX

Additional steps I've attempted

I had found the stackoverflow post you referenced but not read it as much in detail as I did this time around.  I went and deleted the HAX from SDK and manually installed it directly from the directory.  

This caused a little more progress but still not working.  Now when the "faux phone" loads it flashes the Android screen but never loads passed it. 

Here is a paste from the system output when I start it.

D:\Users\Mindcrash\AppData\Local\Android\sdk\tools\emulator.exe -netdelay none -netspeed full -avd Nexus_5_API_21
Creating filesystem with parameters:
    Size: 69206016
    Block size: 4096
    Blocks per group: 32768
    Inodes per group: 4224
    Inode size: 256
    Journal blocks: 1024
    Blocks: 16896
    Block groups: 1
    Reserved block group size: 7
Created filesystem with 11/4224 inodes and 1302/16896 blocks
emulator: device fd:732
HAX is not working and emulator runs in emulation mode
emulator: The memory needed by this VM exceeds the driver limit.
creating window 59 80 449 797

This is pushing outside my areas of experience and I'm not terribly sure where to proceed.  Checked the memory allotments and they seem fine now.  However, when I created a new virtual device it works fine as long as I don't select a "nexus" phone.  

I wonder if this is similar to whatever issue Bucky was having when he said he had to create "buckys phone" in the video.

Does it actually matter if I don't use the Nexus virtuals?
0 Marc Ferrari · January 3, 2015
I have a Note 4, The app I'm trying to build will be used on the note, a Galaxy Note 2014 tablet and a Motorola Xoom tablet.  Is it possible to have the studio auto load to the phone instead of the faux phone?
0 Marc Ferrari · January 3, 2015
If you read up I attempted that step already.  It got the emu to actually work in that I can use none "nexus" virtuals.  Still can't figure out why the Nexus ones refuse to load.
0 Marc Ferrari · January 3, 2015
Just incase anyone reads this and wants to know how to enable USB debugging here are the instructions I found.

To see the option for USB debugging mode in Nexus 4 or Android 4.2 or higher OS, do the following:
Open up your device’s “Settings”. This can be done by pressing the Menu button while on your home screen and tapping “System settings”
Now scroll to the bottom and tap “About phone” or “About tablet”.
At the “About” screen, scroll to the bottom and tap on “Build number” seven times.
Make sure you tap seven times. If you see a “Not need, you are already a developer!” message pop up, then you know you have done it correctly.
Done! By tapping on “Build number” seven times, you have unlocked USB debugging mode on Android 4.2 and higher. You can now enable/disable it whenever you desire by going to “Settings” -> “Developer Options” -> “Debugging” ->” USB debugging”.

Credit to the following for the above information -

Also as a follow-up here is the link for Samsung devices to download the USB drivers -

Lastly, your phone may default to MTP mode for USB. You need to switch it to PTP (Camera) for Studio to pick it up.

Thanks a bunch Sam for helping. Everything is working good and I'm looking at "Hello World" on my Note 4! 
0 David Guillaume · January 3, 2015
My has emulator  won't work so I uninstaled the whole android sdk, and I will reinstall it . Seems like i had too types of sdk and they conflicted with each other.Was that a good idea or will I be in a world of hurt for doing so??
  • 1

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator