Android Emulator not working

+6 Amit Kumar Agrawal · January 1, 2015
Every time I try to run the Emulator, it gets stuck on "Android is Upgrading....Starting Apps". Can you tell me where the problem is ?

Post a Reply

Replies

- page 2
Oldest  Newest  Rating
0 Niels van Oijen · January 3, 2015
Unfortunatly I can't test this solution, when I disable "use host GPU", my emulator hangs at the black screen aka doing nothing and I don't have a mobile device for test purposes
0 Niels van Oijen · January 3, 2015
Ok, made 3 new emulators and 1 booted up, unfortunatly disabling "use host GPU" isn't the solution since the app still crashes :'(


01-03 14:39:11.896    2283-2283/com.extodigital.calculator I/art? Not late-enabling -Xcheck:jni (already on)
01-03 14:39:12.002    2283-2283/com.extodigital.calculator D/AndroidRuntime? Shutting down VM
    --------- beginning of crash
01-03 14:39:12.002    2283-2283/com.extodigital.calculator E/AndroidRuntime? FATAL EXCEPTION: main
    Process: com.extodigital.calculator, PID: 2283
    java.lang.RuntimeException: Unable to start activity ComponentInfo{com.extodigital.calculator/com.extodigital.calculator.Calculator}: java.lang.IllegalStateException: You need to use a Theme.AppCompat theme (or descendant) with this activity.
            at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2298)
            at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2360)
            at android.app.ActivityThread.access$800(ActivityThread.java:144)
            at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1278)
            at android.os.Handler.dispatchMessage(Handler.java:102)
            at android.os.Looper.loop(Looper.java:135)
            at android.app.ActivityThread.main(ActivityThread.java:5221)
            at java.lang.reflect.Method.invoke(Native Method)
            at java.lang.reflect.Method.invoke(Method.java:372)
            at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:899)
            at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:694)
     Caused by: java.lang.IllegalStateException: You need to use a Theme.AppCompat theme (or descendant) with this activity.
            at android.support.v7.app.ActionBarActivityDelegate.onCreate(ActionBarActivityDelegate.java:151)
            at android.support.v7.app.ActionBarActivityDelegateBase.onCreate(ActionBarActivityDelegateBase.java:138)
            at android.support.v7.app.ActionBarActivity.onCreate(ActionBarActivity.java:123)
            at com.extodigital.calculator.Calculator.onCreate(Calculator.java:21)
            at android.app.Activity.performCreate(Activity.java:5933)
            at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1105)
            at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2251)
            at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2360)
            at android.app.ActivityThread.access$800(ActivityThread.java:144)
            at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1278)
            at android.os.Handler.dispatchMessage(Handler.java:102)
            at android.os.Looper.loop(Looper.java:135)
            at android.app.ActivityThread.main(ActivityThread.java:5221)
            at java.lang.reflect.Method.invoke(Native Method)
            at java.lang.reflect.Method.invoke(Method.java:372)
            at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:899)
            at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:694)
0 Niels van Oijen · January 3, 2015
I have set the API to 17 (4.0.3 I think) and put "<uses-sdk android:minSdkVersion="17" />" into my androidmanifest.xml , yet it still crashes, even with a brand new project.

Still gives the same error and in my packages i can only find the v7 package, not the v4 package
0 Niels van Oijen · January 3, 2015
If you want, I can get on Teamviewer to show you.
  • 1
  • 2

Java / Android Development

126,592 followers
About

Very popular language used to create desktop applications, website applets, and Android apps.

Links
Moderators
Bucky Roberts Administrator