Android Studio error

+5 Lasse Heia · December 26, 2014
I'm getting this error when i try to launch the Nexus 5 emulator in Android Studio:

"Cannot launch AVD in emulator.
emulator: ERROR: x86 emulation currently requires hardware acceleration!
Please ensure Intel HAXM is properly installed and usable.
CPU acceleration status: HAX kernel module is not installed!"

I tried to reinstall the "Intel x86 Emulator Accelerator (HAXM installer)" package in the SDK manager.

I also restarted my computer.

Any suggestions?

Post a Reply


Oldest  Newest  Rating
+1 Neil Cannon · December 26, 2014
Check Haxm is installed in SDK manager in extras, if ok then try this

Press start  buttom(window 7) type %AppData% in Search programs and files

Click on Roaming.

C:\Users\ccuk\AppData\Roaming            Change Roaming for Local.

Click on Android, then sdk, then, extras, then intel, then, Hardware_Accelerated_Execution_Manager

Double click on intelhaxm-android and install.

check install is ok on command prompt

Open cmd - type> sc query intelhaxm and press return

You should get the message back:

SERVICE_NAME: intelhaxm
        TYPE               : 1  KERNEL_DRIVER
        STATE              : 4  RUNNING
                                (STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)
        WIN32_EXIT_CODE    : 0  (0x0)
        SERVICE_EXIT_CODE  : 0  (0x0)
        CHECKPOINT         : 0x0
        WAIT_HINT          : 0x0
+1 Lasse Heia · December 26, 2014
Thanks for the quick reply :)

After doing what you said i got an error while installing the intelhaxm-android.exe where it said haxm was not enabled, so i went into my bios and enabled Intel Virtualization Technology.

Then i installed the intelhaxm-android and it worked perfectly :D

Thank you Neil!
+1 Neil Cannon · December 27, 2014

That's great news!

0 Raghuvir Songhela · December 29, 2014

I am facing the same issue. Can you please tell me the detailed steps to enable VT by modifying BIOS? Also, when I type "sc query intelhaxm" in cmd, I get message - "The specified service does not exist as an installed service". Any idea how to solve it?

0 ahmedtarek mahmoud · December 29, 2014
in the boot screen press the bios setup then system you will find virtualization change it to enable
0 Lasse Heia · December 29, 2014

  • First you have to boot into your bios, 

When you start your computer you need to press a button specified in the bootsplash image, if it's not, just try these buttons on your keyboard: del, esc and if this does not work try pressing all the F keys at once.

This is an example:

  • At this point i can't give you any specific instructions, because there is no standard bios so you will have to look through the settings and find Intel Virtualization Technology and choose to enable it, then save and restart.

  • After you have done this look at what Neil wrote earlier in the thread.

If you have any more questions i'm happy to help :)
  • 1

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator