HAX is not working and emulator runs in emulation mode

+4 Arshath Shameer · December 21, 2014
please help me to fix it.

emulator: device fd:688
HAX is not working and emulator runs in emulation mode
emulator: The memory needed by this VM exceeds the driver limit.
creating window 43 59 329 583


Post a Reply


- page 1
Oldest  Newest  Rating
0 Gary Whitney · February 12, 2016
It seems to me:
* HAXM RAM suggestion during installation is based on the RAM available.
   If you only have 4GB, and  your graphics is sharing that memory, then it would be logical to suggest 512MB.
* If you are emulating a newer phone, say Nexus 6, It is going to have a lot of features and software to support the latest API. It is going to need 1GB of memory to  support the software and screen resolution.

I would try emulating a Nexus 4 (or something older, smaller, less resolution) and seeing if you get the same memory error.
If you do increase the HAXM RAM, then only run A.S. and close other applications.
0 Kushal Parikh · February 12, 2016
Try Genymotion. It is far better than inbuilt AVD.
0 Nada Janjetovic · February 11, 2016
My computer ram is 2GB. Intel CPU is support vt-x and hax is installed. Hax memory can use between 512 and 968MB.

This is error message but we have run the emulator

C:\Android\sdkREAL\tools\emulator.exe -netdelay none -netspeed full -avd ProbaFON_API_23
emulator: WARNING: Increasing RAM size to 1GB
emulator: device fd:776
emulator: The memory needed by this AVD exceeds the max specified in your HAXM configuration.
HAXM is not working and emulator runs in emulation mode
emulator: AVD RAM size = 1024 MB
emulator: HAXM max RAM size = 512 MB
emulator: You might want to adjust your AVD RAM size and/or HAXM configuration to run in fast virt mode.
creating window 76 102 308 513
emulator: UpdateChecker: skipped version check

We try to DECREASE AVD RAM to be equals with HAX RAM, but when we start emulator it always  increase to 1GB like you can see in this red WARNING sentence.
Can we adjust AVD RAM to be equals with HAX RAM??
0 Sarah Jackson · January 9, 2015
Did all the above still have this problem
+1 Pam Nhlengethwa · January 8, 2015
You  have to change your AVD's settings and make sure your RAM does not exceed the memory limit you gave to your Intel HAXM. The default value is 1024 . Set it to 1024 or less. 
+1 ahmedtarek mahmoud · December 28, 2014
reduce the ram into 512 then download the Haxm from intel and be sure the virtualization is on from the bios boot screen check out youtube how to turn virtualization on your device 
0 Neil Cannon · December 28, 2014
Check install of hax in sdk manager on extras, if installed move to:

In search box type, %appdata%  and click on roaming........... change to local

Click android then on to extras, intel........ run hax manager install .... set to 512 or 1024 mb.

In AVD make sure ram is either 512 or 1024.

check install.

Open command prompt, cmd type sc query intel haxm

the lines back will includ 4 running if ok.
0 Neil Cannon · December 26, 2014
In the AVD change ram to 1024MB and set the Haxm to 1024MB. Both should be the same valve.
0 Sheetal D · December 24, 2014
I installed the geny motion plugin and it works perfectly.

Just follow this;http://tleyden.github.io/blog/2013/11/22/android-studio-plus-genymotion-emulator/
0 Jordan Dimitrov · December 22, 2014
Im glad we helped you.

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator