HAX is not working and emulator runs in emulation mode

+4 Arshath Shameer · December 21, 2014
please help me to fix it.

emulator: device fd:688
HAX is not working and emulator runs in emulation mode
emulator: The memory needed by this VM exceeds the driver limit.
creating window 43 59 329 583


Post a Reply


- page 2
Oldest  Newest  Rating
0 Sarah Jackson · January 9, 2015
Did all the above still have this problem
0 Sašo Plut · December 21, 2014
try editing the AVD and disable "Use Host GPU"
0 Awesome Flame · December 21, 2014
Found an answer online,
Check it out, it explains. Voice bad though.
0 Sheetal D · December 24, 2014
I installed the geny motion plugin and it works perfectly.

Just follow this;http://tleyden.github.io/blog/2013/11/22/android-studio-plus-genymotion-emulator/
0 Awesome Flame · December 21, 2014
Video about HAXM errors.
0 Neil Cannon · December 28, 2014
Check install of hax in sdk manager on extras, if installed move to:

In search box type, %appdata%  and click on roaming........... change to local

Click android then on to extras, intel........ run hax manager install .... set to 512 or 1024 mb.

In AVD make sure ram is either 512 or 1024.

check install.

Open command prompt, cmd type sc query intel haxm

the lines back will includ 4 running if ok.
0 Arshath Shameer · December 22, 2014
guys i'm still having the problem...!!!!!!!!
0 Miss Diana · December 22, 2014

Hi there, this maybe cause from your AVD setting. Now open AVD manager then, show advance setting and modify your RAM value.. i suggesting 512MB if your computer has low ram. 
0 Jordan Dimitrov · December 22, 2014
I already suggested this Miss Diana :) 
0 Arshath Shameer · December 22, 2014
I just created a new virtual device and executed the app again it worked great.... and it works great
Anyway thanks a lot for all by the way i changed the RAM size too as u suggested....

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator