Possible Android emulator fix (HAXM)

+9 Sašo Plut · December 19, 2014
I am noticing a lot of problems with people running the Android emulator. It says something like x86 emulation not supported, install HAXM etc.. the problem could be solved by creating a new device that uses the ARM emulation not x86.
I remember having similar problems even before i found Android studio and the "fix" (workaround) was using the device that used arm instead of x86.

So make another device using any of these  and send me feedback (it has to say ARMEABI-V7A) then use the new device for your emulation!/images/forum/upload/2014-12-19/5d57eda54d7c0e40c324c497fa2955b0.jpg

Post a Reply

Replies

- page 2
Oldest  Newest  Rating
0 Aadesh Rana · January 10, 2015
The emulator ran but i got the following error messages
../../sdk/emulator/opengl//host/libs/Translator/GLES_V2//GLESv2Imp.cpp:glDetachShader:559 error 0x501
../../sdk/emulator/opengl//host/libs/Translator/GLES_V2//GLESv2Imp.cpp:glShaderSource:1760 error 0x501
../../sdk/emulator/opengl//host/libs/Translator/GLES_V2//GLESv2Imp.cpp:glCompileShader:355 error 0x501
../../sdk/emulator/opengl//host/libs/Translator/GLES_V2//GLESv2Imp.cpp:glGetShaderiv:1273 error 0x501
../../sdk/emulator/opengl//host/libs/Translator/GLES_V2//GLESv2Imp.cpp:glGetShaderInfoLog:1296 error 0x501
Error accepting connection, aborting

anyone know what the problem is?

thanks
0 Shaun Donnachie · January 10, 2015
Every time i try to run avd it gives me this error

 Cannot launch AVD in emulator.
Output:
emulator: ERROR: x86 emulation currently requires hardware acceleration!
Please ensure Intel HAXM is properly installed and usable.
CPU acceleration status: HAX kernel module is not installed!

I have installed all the relevent sdk still dont run 
0 Rehman . · January 10, 2015
@Shaun Donnachie : When you crea the AVD choose ARM in cpu slot instead of x86 it will sort out your problem. hope it will help 
0 Jaquen Burnley · March 15, 2015
A liitle help here!!!!!!!!

Okay so I created a new device like you said..
http://i.imgur.com/4Gc3mLA.png

But when I tried to emulate it, I got this....

http://i.imgur.com/jRgo24i.png

Any suggestions/Help?!
  • 1
  • 2

Java / Android Development

107,094 followers
About

Very popular language used to create desktop applications, website applets, and Android apps.

Links
Moderators
Bucky Roberts Administrator