Emulator HAX Kernel Not installed? Error

+3 Joseph Tey · December 17, 2014
Hi guys, 
I have recently started to watch Bucky's Android for Beginners, and came across this error when I ran the default Nexus 5 emulator.

emulator: ERROR: x86 emulation currently requires hardware acceleration!
Please ensure Intel HAXM is properly installed and usable.
CPU acceleration status: HAX kernel module is not installed!

I have installed the Intel x86 Emulator Accelerator as the tutorial said, and couldn't find any other package that would get the kernel or whatever. 

Please Help :( 

Post a Reply


Oldest  Newest  Rating
0 Nemanja Radevic · December 18, 2014
Did you installed HAXM from SDK manager or manually? Does your processor supports VT and is it enabled?
0 Joseph Tey · December 18, 2014
Is there a guide to install HAXM?
0 Sašo Plut · December 18, 2014
Go to the Android SDK manager and install HAXM. its uder Extras.
0 Nathan Wallestad · December 19, 2014
I am having the same problem. The HAXM is downloaded and I even tried deleting it and installing it again and it still does not work.
0 Sašo Plut · December 19, 2014
there is a few topics with this problem i know in one i saw something about settings in the bios or something like that.. serch trough those.. there is like 10 users  with this problem and everyone started their own tread and the information is scattered across those..
0 Troy Jones · December 20, 2014
I, personally, had to access mine from the cmd line.
0 Abdelrahman Abounegm · December 20, 2014
Hi, I had the same problem, but it got fixed.
Just close Android Studio, uninstall and re-install the HAXM from SDK Manager. You probably have to turn on VT-x / AMD-x from your BIOS (may be named "Virtualization" under the Advanced section) and turn off Hyper-V. This was what fixed it for me. If you don't know how to do any of these, you can simply Google it or reply here again.
0 Adrian Boisclair · January 16, 2015

If you are having issues with the HAXM and it's not working to do what everyone else is saying to do try this:

1.Make sure you've already tried the steps above 
  (Enable Virtualization in the BIOS, as well as Uninstall and Re-Install the HAXM option from the SDK Manager)

2. Exit out of Android Studio.

3.  Download and Instal HAXM DIRECTLY from Intel.

4.  Start Android Studio.

0 Kumar Rohit · April 12, 2015

I am having same problem. I double check everything mention here. In BIOS Intel Virtualization is enable. I downloaded the file intelhaxm.exe and run it but after running sometime it pulls out the error. See the screen shot below./images/forum/upload/2015-04-12/f4896ec851d8ebdc9468d45fa88f58fa.jpg
I am not able to run android studio. Still getting same error. Can anyone help me with this??? 
  • 1

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator