Cannot run App - Android Studio

+1 Robert Summers · December 16, 2014
Hello i cannot run my app, please help. Thanks in return


Post a Reply


- page 2
Oldest  Newest  Rating
0 Sašo Plut · December 19, 2014
Make a new project and run it..  
0 Robert Summers · December 19, 2014
I have tried what was mentioned in the forum and nothing has worked
0 Robert Summers · December 19, 2014
I have tried all these in the AVD

0 Robert Summers · December 19, 2014
I have started a new project and have a new error

0 Sašo Plut · December 19, 2014
by the logs you posted the left one says the emulator had an error and the  right Log simply say the app was not installed and could not find it..
there seems to be some problem with the audio. try this:
go to Run>Edit Configurations. on the left select Android application>App. on the right select tab Emulator and check additional command line options then type this in "-no-audio" (without quotes):

EDIT: try this on the old project.. i need to sleep it over for the second one.. We are making more errors than we are fixing
0 Robert Summers · December 20, 2014
Well from when you said make a new project I deleted all of my old files and now I have created a new file, I have the error shown in your post
0 Sašo Plut · December 20, 2014
restart android studio.. possibly the whole computer :D if it works, great, if not see you tomorrow i need to sleep :P

EDIT: in the future if it doesn't work restart!
0 Robert Summers · December 20, 2014
I have configured "-no-audio" 

After I get this error

C:\Users\Business\AppData\Local\Android\sdk\tools\emulator.exe -avd Robs_Test_Device_API_21 -netspeed full -netdelay none -no-audio
Creating filesystem with parameters:
    Size: 69206016
    Block size: 4096
    Blocks per group: 32768
    Inodes per group: 4224
    Inode size: 256
    Journal blocks: 1024
    Blocks: 16896
    Block groups: 1
    Reserved block group size: 7
Created filesystem with 11/4224 inodes and 1302/16896 blocks
WARNING: cache image already in use, changes will not persist!
WARNING: SD Card image already in use: C:\Users\Business\.android\avd\Robs_Test_Device_API_21.avd\sdcard.img
creating window 61 82 346 553
Error accepting connection, aborting
0 Steven the awesome · December 20, 2014
What probably help is deleting all of the folders generated by android studio. This will delete all your projects, and your'e going to need to  configure android studio again.
0 Robert Summers · December 21, 2014
So basically all my files from studio are being deleted and i have to restart everything

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator