Cannot run App - Android Studio

+1 Robert Summers · December 16, 2014
Hello i cannot run my app, please help. Thanks in return


Post a Reply


- page 2
Oldest  Newest  Rating
0 Robert Summers · December 18, 2014
It's all been set up with AVD, I had to use an arm CPU/ABI since x86 wouldn't work and had been waiting 30 minutes.
0 Troy Jones · December 19, 2014
What does the Logcat say?
0 Robert Summers · December 19, 2014
I restarted it all again and 

The left Log says

C:\Users\Business\AppData\Local\Android\sdk\tools\emulator.exe -avd Robs_Test_Device_API_21 -netspeed full -netdelay none
emulator: warning: opening audio input failed
creating window 61 82 346 553
eglMakeCurrent failed
FrameBuffer::post eglMakeCurrent failed
eglMakeCurrent failed
../../sdk/emulator/opengl//host/libs/Translator/GLES_V2//GLESv2Imp.cpp:glUseProgram:1988 error 0x501

The right Log says

11:57:10 Gradle build finished in 2 min 39 sec
11:59:18 Gradle build finished in 28 sec
12:36:08 Throwable
         Unexpected error: package manager reports that package com.robert.appnameinstore has not been installed: Error executing 'dumpsys package com.robert.appnameinstore:
         device not found'
12:36:17 Session 'app': error
12:36:18 Session 'app': error
12:38:38 Gradle build finished in 56 sec
12:40:52 Gradle build finished in 22 sec
0 Neeraj Singh · July 23, 2015
It is App sign issue please uninstall old app from device after that reinstall issue will be resolved.
0 Steven the awesome · December 19, 2014
Maybe this Forum topic solves your'e problem.
0 Sašo Plut · December 19, 2014
Make a new project and run it..  
0 Robert Summers · December 19, 2014
I have tried what was mentioned in the forum and nothing has worked
0 Robert Summers · December 19, 2014
I have tried all these in the AVD

0 Robert Summers · December 19, 2014
I have started a new project and have a new error

0 Sašo Plut · December 19, 2014
by the logs you posted the left one says the emulator had an error and the  right Log simply say the app was not installed and could not find it..
there seems to be some problem with the audio. try this:
go to Run>Edit Configurations. on the left select Android application>App. on the right select tab Emulator and check additional command line options then type this in "-no-audio" (without quotes):

EDIT: try this on the old project.. i need to sleep it over for the second one.. We are making more errors than we are fixing

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator