Hey guys, not sure how many people have had this problem, but I finally found a solution to this incredibly annoying problem. Basically your installed ram shows up in cpu-z as the correct amount, but for some strange reason, no matter what bios settings and ram configurations you try,  you can't get it past a certain limit. Windows computer settings will show a "usable memory" less than what you've installed. In my case it was 5GB.

SOLUTION: Use the shortcut "windows button" + "r" to bring up the run window, then type in msconfig, then go to the "boot" tab, then click "advanced options", and finally uncheck "maximum memory" and click apply. Now reboot and enjoy your full amount of ram.

If just one person finds this useful, I'll be a happy man.