Can't upload avatar

+1 jan burg · November 7, 2014
I'm on Kali linux x64. I'm trying to upload an image and I keep getting an "i/o error" that shows. I'm sure other people with linux have done this successfully, so let me know if ya'll got a way around this. I've tried this on iceweasel(Kali's firefox) as well as chromium. On chromium, I don't even get the button to upload.

Post a Reply


Oldest  Newest  Rating
+1 jan burg · November 21, 2014
Still having issues with this on windows 7 x64 as well. Getting the "IO error" when trying to upload. Not sure what the issue is. Need my avatar!
+2 Bucky Roberts · November 21, 2014
For Windows 7, what browser are you using? Also, do you have to image file already uploaded somewhere else online? If so, can you please post a link to it? I will download it and see what is causing the error. 
+1 Çağlan Turgut · November 21, 2014
Do you have java and flash installed? It worked for me when I installed them. You can also try a different image format to test if its caused by the image.
0 jan burg · November 21, 2014
@Bucky : That would be great man. I uploaded the image here :
On windows 7, I'm using firefox. On Kali, I tried using Chromium and Iceweasel(Kali's firefox).

Edit : Just tried using chrome on Windows and it worked fine!! Yay. Thanks for the reply though.

@Ça?lan : Thanks for your reply. Yeah I tried with a png and jpg and made sure to install java, but on linux the plugin is an opensource plugin called IcedTea and throws errors sometimes, so it might be that. I'll look into it further. I still get errors with other stuff with this goddamn IcedTea plugin. Linux can be such a b**** sometimes lol.

Edit: I think I've started to figure out the problem on linux. You need to download a jquery plugin with:

sudo apt-get install libjs-jquery*  

I now get the "upload photo" button to appear briefly. Stuff like adding comments and liking posts no longer gives "invalid request" so that's good!
  • 1

Bug Reports


Found a bug on the site? Report it here. For all security related bugs, please send me a private message.

Bucky Roberts Administrator