Error Downloading Eclipse

+2 Haifa BB · November 5, 2014
Hello, I already downloaded and Installed Eclipse but whenever I try to open it it show me an error that says ''' The JVM shared library "/Library/Java/JavaVirtualMachines/jdk1.8.0_25.jdk/Contents/Home/bin/../jre/lib/server/libjvm.dylib" 
does not contain the JNI_CreateJavaVM symbol.'''
How can I fix that??

**I am running it in mac OS X Yosemite


Post a Reply


Oldest  Newest  Rating
0 Troy Jones · November 9, 2014
I got the same thing.  It was because jdk and eclipse both have to be either x86 or x64. They can't be different.
0 Haifa BB · November 8, 2014
Well I deleted it and relaunched it again and it worked.  Maybe there was something wrong in the first installation. 
Thank you all for helping .. 
-1 jan burg · November 8, 2014
On linux, I had trouble getting eclipse to run at first. You may need to configure a few things similar to what I had to do.

Try executing these environment declarations in the terminal before launching eclipse:

JAVAHOME=<directory where java/jdk is installed>

If this works, go ahead and add the two lines to your bashrc.

**Only try what I've posted below if macs use /usr, I have no idea. Basically check if you have a /usr/bin if you're not sure. If you don't have it, this probably won't help.

The other thing I had to do was link java and javac from the <jdk...>/bin/ directory to /usr/bin, i.e.,
sudo ln -sf <jdk...>/bin/java /usr/bin/java
0 Haifa BB · November 8, 2014
Yes, I did all these ..
0 Kuroodo Ditory · November 5, 2014
Though I don't have the answer or any idea what it is, let's troubleshoot:

1.Did you download the correct version of eclipse?

2.Did you download the latest version of eclipse?

3.Do you have the latest version of Java?

4.Have you tried following the Java tutorial videos (at least videos 1, and 3) ?
  • 1

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator