AVD not running correctly

+1 John Brune · February 9, 2016
Hello Everyone
I have been working on this problem for about a week now and just I just can't seem to get the emulator working correctly. When I fire it up, it will say  HAXM is installed and running in the fast page mode but the emulator  will just sit at the Android screen , once or twice it has gone to the home screen but then gives a message that the system has stopped. Windows then gives me a HAXM.EXE has stopped running and the computer locks up and I have to reboot. The computer I am running is a HP Compaq dc7900 Convertible mini tower which is a 64 bit dual core machine with 4gb ram.
I hope someone can give me a little insight on this as at this point I am not making any progress.
John Brune

Post a Reply


Oldest  Newest  Rating
+2 Kushal Parikh · February 10, 2016
Try using Genymotion. It is far better than inbuilt AVD. Works great with 4 gb of ram + 4 gb pendrive(ReadyBoost mode).
0 Gary Whitney · February 10, 2016
The fact that it worked and then stopped is puzzling.
My usual advice about installing it doesn't seem to apply here.
Two thoughts:
4 gb isn't a lot of ram
I have seen posts about needing to disable a Windows VM. But I thought that was only installed if you set up the machine to be a server.
Check out this post: https://thenewboston.com/forum/topic.php?id=11197

Sorry  I can't be more help.
Here is my usual advice. Maybe the link has something that can help you.
There are different AVDs, Those that use x86 and those that don't.

If you have  and Intel processor that supports HAXM then you can use the AVDs that use x86 system images.

Click the device you want to use in AVD manager and click the  edit icon.

   the second line down will confirm if the device is using an x86 system image.

If  you don't have and Intel processor you will need to clone the device and modify it so it has a non x86 system image.

If you do then here is my "canned" answer.

1. You need to have an Intel chip set that supports HAXM.

2. You have to turn it on in your BIOS

3. You need to download AND install HAXM in your SDK manager.

I found this link and followed instructions for installing using Studio >  Tools > Android> SDK Manager

0 John Brune · February 11, 2016
Gary & Kushal
Thanks for the reply's, I think the next step I'll try will be Genymotion. It sounds like a good tool to have no matter what.
  I have tried reinstalling both HAXM and Android Studio using different Bios setting and nothing seems to help. The Bios settings are not that straight forward on the HP but I think I have that part right now. I have even tried on a identical machine as I have several of them.  They are a basic office machine but they are not bad, the video system is kinda week. I am thinking it might need a graphic card but trying more ram is much easier so I will try that first. I would like to get the emulator working but hopefully Genymotion will work for now. 
0 Jake E · February 11, 2016
I just tried Genymotion and it works like a charm, saved me a lot of headache!
  • 1

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator