i can't use the AVD , i have always the same error ( cannot launch AVD in emulator

+1 lakhdari k · January 27, 2016
:(i can't use the AVD , i have always the same error
 ( cannot launch AVD in emulator ; ....... HAX kernel mudule is not installed.)
 can you help me 

Post a Reply


Oldest  Newest  Rating
0 Peter Staal · February 3, 2016
Windows 8 and 10 will not allow you to install HAXM from Intel. You can go to Search and type Windows features and then Program and featers.
Or go to ControlPanel and find Program and featers. Here you can disable Hyper V. Now you can install HAXM driver from Intel. Then your emulator will work. This worked for me.
0 Appi M · February 2, 2016
Do what bucky does in his 2nd or 3rd video. Go to Sdk manager -> sdk tools -> install Intell x86 Emulator Accelerator.

If the error persists than instead of a Blank Activity  create a Empty Activity.

I had this problem for ages (ie upto video 10) after which I just couldnt go on so I searched and searched online. Got many ans and tried them all, but finally found the above mentioned solution on THIS VERY FORUM (cue Facepalm!) 

A guy whose name I dont remember gave the ans but his name starts with T. Thanks Mr T. I lost ur ans b4 I could give it a thumbs up.
0 Gary Whitney · January 29, 2016
Basically the error is stating that you did not turn VT-x in your BIOS?

Editing the BIOS is a risky activity. You can mess up your computer.
Research it before trying and remember this:
1. You have to reboot not restart your computer to access the BIOS.
2. Use the Exit without saving button if you aren't sure about any changes you made.
0 lakhdari k · January 29, 2016
thank you ;
i tryed to follow this instructions but i have a problem with my intel processor ( the IVT )
can you help me to fixe it , 
+1 Paul Miil · January 28, 2016
or you can just plug into an android device via usb and skip the virtual device all together.
+1 Gary Whitney · January 28, 2016
This must be the most asked question on this site.
There are different AVDs, Those that use x86 and those that don't.

If you have  and Intel processor that supports HAXM then you can use the AVDs that use x86 system images.

Click the device you want to use in AVD manager and click the  edit icon.

   the second line down will confirm if the device is using an x86 system image.

If  you don't have and Intel processor you will need to clone the device and modify it so it has a non x86 system image.

If you do then here is my "canned" answer.

1. You need to have an Intel chip set that supports HAXM.

2. You have to turn it on in your BIOS

3. You need to download AND install HAXM in your SDK manager.

I found this link and followed instructions for installing using Studio >  Tools > Android> SDK Manager


If your CPU is not Intel then don't use any of the x86 image AVDs.

If your CPU is AMD then use armeabiv7 system image.

One other thing. if you check the use GPU when you configure your device you are directing the AVD to use graphics acceleration. Don't check this if you don't have the BIOS and  driver to support it.
For more information see http://developer.android.com/tools/devices/emulator.html
  • 1

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator