Can't Install Intel HAXM

+4 Shibaprasad Bhattacharya · January 4, 2016
/images/forum/upload/2016-01-04/f72499bbbf6c78658f5798cccbe86a3e.jpg

I am currently using the latest version of Android Studio. Following the video lecture of youtube I couldn't install Intel HAXM. In what way I can install it now to run AVD?
Thanks in Advance!

Post a Reply

Replies

- page 1
Oldest  Newest  Rating
+1 Romesh Binwani · January 4, 2016
Hi Shibaprasad,

Open SDK Manager in SDK manager window click on Launch Standalone SDK Manager.

in SDK standalone window scroll all the way to down.

Where you can find Inter x86 Emulator Accelerator (HXAM installer) .

Install that.

Thanks,
Romesh
0 Edwin West · January 4, 2016
i am having the same problem,even after installing HAXM, i need help pls reply
+2 Darren Reeder · January 5, 2016
Hopefully this might help

0 Gary Whitney · January 5, 2016
There are different AVDs, Those that use x86 and those that don't.

If you have  and Intel processor that supports HAXM then you can use the AVDs that use x86 system images.

Click the device you want to use in AVD manager and click the  edit icon.

   the second line down will confirm if the device is using an x86 system image.

If  you don't have and Intel processor you will need to clone the device and modify it so it has a non x86 system image.

If you do then here is my "canned" answer.

1. You need to have an Intel chip set that supports HAXM.

2. You have to turn it on in your BIOS

3. You need to download AND install HAXM in your SDK manager.

I found this link and followed instructions for installing using Studio >  Tools > Android> SDK Manager

https://software.intel.com/en-us/android/articles/installation-instructions-for-intel-hardware-accelerated-execution-manager-windows
0 Levi Henry · January 5, 2016
Follow the video that Darren has posted.  If you still get an error, try uninstalling Avast Anti-Virus and following the same steps.  
0 Montana Braswell · January 6, 2016
Hi Shibaprasad,

  I had the same thing, I sadly forgot the Youtube video that helped me to give him credit, but when you go to your AVD manager, hit create new virtual device. After that choose any Nexus phone you'd like. Then when you get to System Image and it goes over which Release name you'd like,  make sure which ever you pick on the ABI side has the "armeabi-v7a" It works better with people who have an AMD graphics card like me. When you finish selecting, you can name your phone something like TEST  so you can remember which phone will actually load.

Hope this helps!  :3 

-Montana
0 Christopher Li · January 7, 2016
you must enable Intel Virtualization Technology in your bios
0 Bakari Morris · January 7, 2016
Thanks for the link darren, after following the video I finally got my AVD running. (I have a i7 intel processor and not an AMD)
0 Nasir Yayu · January 9, 2016
Hello, I need your help...
I have installed Android Studio Bundle 141.22 om my system HP635 with this specifications:
Processor: AMD E-450 APU with Radeon(tm) HD Graphics 1.65GHz
RAM: 8.00GB. 64-bit O.S, x64-based processor.
But, when ever I lunch the app. it lunch with some errors,

1, Error:(23, 17) Failed to resolve: junit:junit:4.12.

2.  Cannot launch AVD in emulator.
Output:
emulator: ERROR: x86 emulation currently requires hardware acceleration!
Please ensure Intel HAXM is properly installed and usable.
CPU acceleration status: HAX kernel module is not installed!

And Android manager shows HAXM is installed and Intel Visualization manager is already enable in Bios setup, and I try Installing  Hardware_Accelerated_Execution_Manager manually and it fails, the error message is : "This computer does not support Intel Virtualization Technology (VT-x). HAXM cannot be installed"
And I also unchecked Hyper-V option on Windows Features and system restart but noting change and the Android Studio lunched with the same ERRORS.
Please help.
0 Dilraj Singh · January 10, 2016
Hi,

I am getting issues while installing the exe file present under C:\Android\sdk\extras\intel.

Below is the error:

/images/forum/upload/2016-01-10/cf5e4bcc2d952f743c65adc165c7324e.PNG

I have installed Virtual Box on top a physical Laptop (i5 processor, 4 GB RAM, and Virtualization supported and enabled on my physical laptop). I am using Speccy tool to check this.

First I installed the speccy S/W on my physical  machine and it showed as Virtualization: Supported and Enabled. Then I ran the same program on my virtual Box and it there it showed as Virtualization: Not supported. In my understanding the Processor or other Setting should directly match with the virtual machine while creating one. So, according to me if virtualization is supported in my physical device then it should be supported in virtual as well, Though, I have enabled VT-x in by Virtual Box.

/images/forum/upload/2016-01-10/25836817fd37fb07337190c6d01f6eda.PNG

I don't have any option such as Hyper-V under "Turn Windows Program On-Off". So, that thing is out of the picture.

My both Virtual and Physical Machine are running Windows 7 OS.

Please help in installing that exe file.

Thanks!
DILRAJ
  • 1
  • 2

Java / Android Development

107,319 followers
About

Very popular language used to create desktop applications, website applets, and Android apps.

Links
Moderators
Bucky Roberts Administrator