Question about Themes

+1 Chase Dawson · January 4, 2016
When I create a new activity or change the them of my activity, I get a message that says there are rendering problems and it cannot find the following class:

android.support.design.widget.CoordinatorLayout

and because of this I am unable to add any of the widgets to my app.
Any ideas on how to fix this?

Post a Reply

Replies

Oldest  Newest  Rating
+1 Gary Whitney · January 5, 2016
The theme,  the Activity, and the SDK tools are closely related.

If you recently downloaded Android Studio then you are at API 23 which uses toolbars instead of actionbars.

If you try to change the theme to something from and older API you get rendering problems because the library the Blank Activity chose doesn't support older themes.

I suggest the following, until you get some more experience.

* Create an Empty Activity. Not a Blank Activity.
* Don't change the type of activity i.e. leave AppCompat
* See that little droid icon with 23 next to it. Change it to 21. That is what was used at the time the tutorials were created.
0 Hans D · January 4, 2016
I got exactly the same problem.. Don't know how to fix it too.
Can someone help please?
0 Chase Dawson · January 5, 2016
Changing to an empty activity helped a lot. But am I now unable to use any of the other given activities, like the maps or tabbed activities?
0 Gary Whitney · January 6, 2016
Chase,
Using an Empty Activity should not have an effect on the other activities.

I could be wrong but ...
Maybe your min API is too low to support those kinds of activities.
Going below 16 doesn't buy you that much more market and it definitely limits what you can do.
  • 1

Java / Android Development

107,072 followers
About

Very popular language used to create desktop applications, website applets, and Android apps.

Links
Moderators
Bucky Roberts Administrator