Android Minimum API

+1 Shahabas Shakeer · December 2, 2015
I was wondering if its necessary to download the older API versions of android
(such as android 2.2, 3.0, 4.0 etc.). I want to set the minimum API level to 2.2 Froyo, but
I have only Android 6.0 M installed. So if I want to make the app compatible with all the
previous versions (starting from 2.2), should I download all previous API versions?

Post a Reply


Oldest  Newest  Rating
0 Gary Whitney · December 2, 2015
When you start a new Activity, Android should make your activity  extend AppCompatActivity automatically if you set the min API to something less than the latest.

My question is why do you want to go back all the way to Froyo.
  • 1

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator