AVD is not working

+1 Aliaa Nemir · December 2, 2015
I opened Avd for the first time but it took more than 2 hours now and it's still showing the same black screen with android written on it, I don't if there's some kinda error that's blocking it from starting.
So how can i fix this please??

Post a Reply


Oldest  Newest  Rating
0 Gary Whitney · December 2, 2015
AVDs take a long time because they try to emulate the devices hardware and software.
2hrs is unacceptable.
Are you simply cloning an existing device?
Do you have an old CPU?
Do you not have enough memory?

If your CPU is made by Intel you should pick an x86 device. Also you should look into installing HAXM.

If all else fails you can install the GenyMotion emulator. I hear it is pretty good.

Search this forum for Public. It should turn up a public service post about AVD problems.
0 Sachi Bucky · December 3, 2015
Crazy Emulator just went bisserk on me!!  The error box is not closing with the message,"Cannot load AVD list.  Invalid content was found starting with element d:skin.  No child element is starting at this point.
0 Sachi Bucky · December 3, 2015
Sachi Bucky here.I put out a desperate note earlier for help.  I solved the loopy problem just by deleting the whole virtual device.  Problem solved the error loop.
0 john chua · December 3, 2015
hey guys , sorry i have this problem regarding AVD too =) any ideas ?i did install like the video did /images/forum/upload/2015-12-03/36e9dbeab3b4c4ac0d99e20a3052b2bb.png
0 Aliaa Nemir · December 3, 2015
Well, yes i have an old CPU and not a big memory.
But can i test the apps on my android device instead of the AVD??
0 Gary Whitney · December 3, 2015
This topic is the most frequent topic on this forum.
To answer you recent question in a word Yes.

For the sake of the other posts let me post this here.

There are different AVDs, Those that use x86 and those that don't.

If you have  and Intel processor that supports HAXM then you can use the AVDs that use x86 system images.

Click the device you want to use in AVD manager and click the  edit icon.

   the second line down will confirm if the device is using an x86 system image.

If  you don't have and Intel processor, you will need to clone the device and modify it so it has a non x86 system image.

If you do have and Intel processor, then here is my "canned" answer.

1. You need to have an Intel chip set that supports HAXM.

2. You have to turn it on in your BIOS

3. You need to download AND install HAXM in your SDK manager.

I found this link and followed instructions for installing using Studio >  Tools > Android> SDK Manager

0 Rakshanda Phate · December 7, 2015
Solution is here: http://howcanicode.com/2015/12/emulator-error-x86-emulation-currently-requires-hardware-acceleration/
  • 1

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator