HAXM problem

+1 Bill Bilson · November 12, 2015
Cannot launch AVD in emulator.


emulator: ERROR: x86 emulation currently requires hardware acceleration!

Please ensure Intel HAXM is properly installed and usable.

CPU acceleration status: HAX kernel module is not installed!

Running Windows 8.1 Home

Went through the install process in SDK

HAXM download complete


Post a Reply


Oldest  Newest  Rating
0 vizual swami · November 13, 2015
You'll need to enable the ARM system image under SDK platforms > Android 6. Restart as admin and go to AVD manager> create virtual device, after you select hardware, make sure you select ARM as your system image. That error should be gone. I should note this worked on win7 64 bit.
0 Evgeny Chulak · November 13, 2015
Hi Bill,

I had the same problem.

Before installing anything you need to make sure "Virtualization Techcnology" is enabled in bios. Bucky does not mention that in his tutorials and took me a few minutes to figure it out.

After that you should be able to install as normal.
0 Gary Whitney · November 13, 2015
One More "gotcha" the HAXM isn't installed until you run the exe file.
Follow the link at the bottom of this summary.
There are different AVDs, Those that use x86 and those that don't.

If you have  and Intel processor that supports HAXM then you can use the AVDs that use x86 system images.

Click the device you want to use in AVD manager and click the  edit icon.

   the second line down will confirm if the device is using an x86 system image.

If  you don't have and Intel processor, you will need to clone the device and modify it so it has a non x86 system image.

If you do have and Intel processor, then here is my "canned" answer.

1. You need to have an Intel chip set that supports HAXM.

2. You have to turn it on in your BIOS

3. You need to download AND install HAXM in your SDK manager.

I found this link and followed instructions for installing using Studio >  Tools > Android> SDK Manager

0 Alan . · November 14, 2015
"You'll need to enable the ARM system"  That is if you are running an AMD CPU.  HAXM is for Intel CPUs
0 Bill Bilson · November 14, 2015
Hi guys, thanks for the responses.

I looked through the bios for a while yesterday and I couldn't find any mention of virtualisation.   I found VT-d but nothing on VT-x or "Intel virtualisation technology".

Also, I'm running an I5-4460 @ 3.2 GHz and it isn't listed on this page

The 3.4 GHz 4460 listing indicates that it does have VT-x capability.

Where in the bios would it be (I have looked everywhere)?  
0 Bill Bilson · November 14, 2015
So I figured out how to turn on the Intel Vt-x feature and reinstalled HAXM in android studio but it still isn't working.

I watched a video a couple days ago that said you need to disable some windows feature that wasn't listed on my computer before I fixed the VT-x issue and now it still isn't listed.

I don't know what to do.
0 Bill Bilson · November 15, 2015

Please Help!

Intel Virtualization is enabled.  HAXM is reinstalled on Android Studio.  Emulator still not working.

0 Leon Farchau · November 16, 2015
If you're useing windows 8 or earlier, you have to disable hyper v, because it blocks VT-x.
That is the only thing, wich helps me :)
  • 1

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator