Drag and drop widgets not working

+1 Archana kulkarni · November 3, 2015
I am following the very first tutorial of the series:"Android App Development for Beginners". Had problems with HAXM; but figured it out and fixed it.
Now , i am not able to drag widget . i see a circle and backslash on it while trying to drag.
when i launch android studio, i get rendering problem. it hides after  a while. i don't know how to access it after it hides.
Please help. I am stuck and have no idea what to do.

Just started another project and now it is working.
As it was  just start of the project, it is fine for me.
 But would like to know what could have been problem.

Post a Reply


Oldest  Newest  Rating
0 Tommy Jackson · November 7, 2015
I am having this exact same problem! Same scenario too, as I had trouble with HAXM at first as well. I still get the rendering problems and am unable to drag and drop widgets so if anybody does know what the problem is help would be greatly appreciated!
0 vinay anand · January 30, 2016
I am facing the same problem. Did you find a fix for that?
0 vinay anand · January 30, 2016
well, I figured it out. Even though the design panel is visible as well as the Palette and Component Tree I ALSO need to have app/src/main/res/layout/fragment_main.xml selected over in the Project panel in order for the actual design of the layout to be enabled.
0 Gary Whitney · January 31, 2016
The direct answer is:
Blank Activity creates TWO layouts.
1. activity_main.xml
2. content_main.xml

You can drag and drop on to content.

My answer is:
If you are going to follow the tutorials then start with an Empty activity NOT a Blank activity.
change the API23 icon to API21.
  • 1

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator