I installed Android Studio yesterday (Windows 7 x64), but it won't go beyond the splash screen. How come? Here's what I did:

Downloaded and installed the newest Java SDK (1.8.0 u66, x64)
Downloaded and installed Android Studio (android-studio-bundle-141.2288178-windows.exe)
Created an Environment Variable called JAVA_HOME and set it to point to C:\Program Files\Java\jdk1.8.0_66

I tried to open Android Studio at this point (both normally and "Run as administrator"), but it wouldn't go further than the splash screen. The splash screen appeared, but the progress bar didn't show, and nothing happened for an hour. So I fired up SDK Manager and updated/installed the 10-ish packages that are selected by default. The same thing still happened. The "studio64.exe" process shows up in two instances in Task Manager, one that takes up ~2,5MB of RAM, and one that takes up ~75MB of RAM. The CPU usage of the 75MB RAM instance is 25% for 2 seconds (it's maxing out one of my 4 cores), and then it instantly turns to 0% and stays there. The other one is 0% at all times. I have to close these through the task manager since I can't do anything on the splash screen alone.

When I went to C:\Program Files\Android\Android Studio\bin and ran the 32-bit executable (just to try), it told me to install a 32-bit Java SDK because it couldn't find one on my system (which is correct, I did not have a 32-bit Java SDK installed on my computer). I then installed the latest 32-bit Java SDK, and now the 32-bit executable is having the EXACT same response when I run it (both normal and "Run as administrator"). This leads me to believe that there is no problem with my 64-bit Java SDK installation.

Am I missing something?

Any help would be greatly appreciated.


I've let the 32-bit version splash screen stay idle for the past hour, and it finally launched! I'm currently downloading and installing components through the Android Studio Setup Wizard. I guess I'll give waiting another try and see if it solves the issue for the 64-bit executable as well! Maybe the hour wasn't enough.

I'll report back if I get the 64-bit version running the same way.


It worked on the 64-bit version as well! I'll let this topic stay so that people with the same confusion can benefit from my experience.

Have fun programming!