Getting "Failed To Install HAXAM" Message and More Errors

+1 Tommy Morris · October 28, 2015
Hi everyone, I am new to app development and new to the community.  I took a few programming languages years agon but has worked as a non-programming engineer.  There are apps that I want to develop so I decided to brush up on my programming skills.  I hope everyone will have patience with me as I ask a few questions.

1.  I downloaded and installed Android SDK and Java JDKs.
I downloaded and installed more than on JDK, including NetBean.  Does it cause problems to install more than one JDK?

2.  While installing the Android SDK I got the following message:
"Failed to install Intel HAXAM.  For details please check the installation log.  “C\Users\tommylee\AppData\Local\Temp\nsaB591.tmp\haxm_silent_run.log”.

3.  After installing the Android SDK and running it as Administrator I got the following error message:
"Error:(24, 13) Failed to resolve: com.android.support:appcompat-v7:23.1.0

<a href="install.m2.repo">Install Repository and sync project</a><br><a href="openFile:C:/Users/tommylee/AndroidStudioProjects/MyApplication2/app/build.gradle">Show in File</a><br><a href="open.dependency.in.project.structure">Show in Project Structure dialog</a>".

Can someone please advise?

Thanks in advance

Post a Reply

Replies

Oldest  Newest  Rating
+1 Gary Whitney · October 28, 2015
Tommy
I am no expert but here is what I think.
1. It probably doesn't hurt to have 2 JDKs but A.S. needs to know which one. The default is the Java jdk and it probably picked that one.
2. Read the following and keep it handy in case you upgrade the HAXM (like I did today)
There are different AVDs, Those that use x86 and those that don't.

If you have  and Intel processor that supports HAXM then you can use the AVDs that use x86 system images.

Click the device you want to use in AVD manager and click the  edit icon.

   the second line down will confirm if the device is using an x86 system image.

If  you don't have and Intel processor you will need to clone the device and modify it so it has a non x86 system image.

If you do then here is my "canned" answer.

1. You need to have an Intel chip set that supports HAXM.

2. You have to turn it on in your BIOS

3. You need to download AND install HAXM in your SDK manager.

I found this link and followed instructions for installing using Studio >  Tools > Android> SDK Manager

https://software.intel.com/en-us/android/articles/installation-instructions-for-intel-hardware-accelerated-execution-manager-windows

3 support lib. When I installed version 23 the support library was not  downloaded and I had to do it manually.

Good luck
0 Parth Gupta · October 31, 2015
https://software.intel.com/en-us/android/articles/intel-hardware-accelerated-execution-manager-end-user-license-agreement

heres the link.download andinstall the HAXM .
0 Tommy Morris · November 1, 2015
Two things:

1.  The Android SDK Manger shows the Intel x86 Emulator Accelerator (HAXM installer) is "installed."

2.  I downloaded the HAXM and tried to install it again and got the error message that it could not be installed because I need to turn on the "Intel Virtualization Technology (VT-x)" in the BIOS settings.  I went to the settings and found it under "Advanced" > "Configuration"...but it was grayed out and I could not select it.  Any ideas on what I can do to get access to it?

Thanks in advance.

Tommy
0 Tommy Morris · November 2, 2015
Nevermind...I got the issue resolved.  The issue was that I was accessing BIOS as ADMINISTRATOR, and given that, I did not have access to enable the Intel Virtualization Technology VT-x...once I logged in as GUEST I was able to enable it.

Thanks everyone.
0 Gary Whitney · November 1, 2015
Maybe your CPU doesn't support it.
Do you have an I3,5,or 7?
They should support it.
I have an I5 and it was not greyed out.

I have read posts that indicate the Genymotion emulator is fast if you want to try that.
https://www.genymotion.com/#!/developers
0 Tommy Morris · October 30, 2015
Thanks.  I appreciate your taking the time to respond.  I will try your suggestion and let you know how it goes.

Again, thanks.
  • 1

Java / Android Development

107,058 followers
About

Very popular language used to create desktop applications, website applets, and Android apps.

Links
Moderators
Bucky Roberts Administrator