Problem while installing Android Studio..

+3 Nirjan Munshi · October 28, 2015
Today i am going to install Android Studio. I have tried several times but all time one error occurs. A message box comes where this message appears "Failed to install Intel HAXM.  For details, please, check the installation log: C:\Users\COMPU\AppData\Local\Temp\msx5D4C.tmp\haxm_silent_run.log "
What to do... please help

Post a Reply


- page 1
Oldest  Newest  Rating
0 Nirjan Munshi · November 2, 2015
Yes i have done that too. also downloaded the intel haxm file externally from intel site. but the problem remains same. i am using intel i3 3rd gen processor. and my ram is 4 gb. 

 at first when i have not installed the intel haxm the problem was like "failed to installed intel haxm ... "
and after installing the problem become failed to update intel haxm.. and after that the huge msgbox appeared that i posted earlier. 
0 arvind Venkatesh · October 31, 2015
Dont worry i will help.

First go to your BIOS.
then find for a option that says enable hardware accelaration...set it to true(ie it must be enabled).
after that restart your system
got to your sdk directry->extras->intel->Hardware_Accelerated_Execution_Manager->
run "intelhaxm-android.exe" it as admin by right clicking on it..

if you get any error please post it here
Hope this helps...:angel::ermm::'(
0 Akshay Narula · October 30, 2015
Make Sure Your System's 1GB RAM  is free for Android studio and HAXM, 
0 Nirjan Munshi · October 30, 2015
Not working this step... need something more
0 Suleman Ahmed · October 30, 2015
Gary Whitney · October 28, 2015

I am no expert but here is what I think.
1. It probably doesn't hurt to have 2 JDKs but A.S. needs to know which one. The default is the Java jdk and it probably picked that one.
2. Read the following and keep it handy in case you upgrade the HAXM (like I did today)
There are different AVDs, Those that use x86 and those that don't.

If you have and Intel processor that supports HAXM then you can use the AVDs that use x86 system images.

Click the device you want to use in AVD manager and click the edit icon.

the second line down will confirm if the device is using an x86 system image.

If you don't have and Intel processor you will need to clone the device and modify it so it has a non x86 system image.

If you do then here is my "canned" answer.

1. You need to have an Intel chip set that supports HAXM.

2. You have to turn it on in your BIOS

3. You need to download AND install HAXM in your SDK manager.

I found this link and followed instructions for installing using Studio > Tools > Android> SDK Manager

3 support lib. When I installed version 23 the support library was not downloaded and I had to do it manually.

Good luck
0 DARWIN V TOMY · October 30, 2015
May be You are using AMD system .HAXM will not work on AMD ,Try Genymotion emulator , ignore the haxem warning ,You dont need it if you are using third party emulators like Genymotion 
0 Nirjan Munshi · October 30, 2015
yes. i have got the same message that you posted in your screen shot. and after clicking on the button "OK" it shows that installation complete. now when i run this Android studio as an Administrator it starts to load and after few seconds it gives a big error. i am sending the screen shot./images/forum/upload/2015-10-29/1df35e219ddf3685067d89c1d9b28851.PNG
0 Akshay Narula · October 29, 2015
0 pro Protik · October 28, 2015
I have got the same error. what to do ? /images/forum/upload/2015-10-28/2112bae5de0ba9589930511a90613786.png
0 pro Protik · October 28, 2015
I have the same error. Some one help please.
  • 1
  • 2

Java / Android Development


Very popular language used to create desktop applications, website applets, and Android apps.

Bucky Roberts Administrator